24 September 2015

xcode7 を入れると `node-gyp` でエラーが出る

xcode7 に更新すると、おそらく gcc まわりの更新の影響で、node-gyp まわりのエラーがでるようになった。その結果 atom の一部のプラグインが動かなくなった (rebuild に失敗する)。具体的には ever-notedown

結論としては node をビルドし直すと解決した。

  • gcc まわりの更新によるものっぽいので、とりあえず node をソースからビルドし直すと大丈夫だった
    • nvm を使っているので、nvm install -s <version>
    • nvm install で落ちてくるバイナリは非対応だったので、ソースからビルドしなおした
  • 関連ありそうな issue はこれ?

あまり騒がれている話を聞かないんだけど、自分の環境だけだろうか… (そんなに特殊なつもりはないのだけれど)